No Lights

Solder a length of wire on to the pin on the back of a bulb.  Now whilst holding the metal surround of the bayonet part of the bulb on to an earth you can test for a feed by touching the bared end of the wire you've soldered to the bulb on to suspected live feeds.

1. Check we have electrical power coming out of the engine.  The yellow wire (brown on Indian loom) coming out of the mag flange comes directly from the lighting coils.  With the bike running this should be permanently live and unregulated (it will pop bulbs when you rev up).   Use your tester to ensure power is coming out of the yellow wire while the bike is ticking over.  (Do not rev the bike, as it will pop the bulb).  

(Working) if the bulb lights up the flywheel and stator are doing their part of the job perfectly, and you can move to step 2. 
(Not Working) If the bulb does not light up the flywheel and stator are not producing current and this will have to be corrected before your lights will work. The most common cause of this will be damage to the yellow wire coming from the stator it may be trapped behind the stator and bared to earth, or rubbed through and touching to the engine casing.  This has to be visually verified. 

If you have a multi meter the lighting wire should read as an earth (ie zero resistance between the engine casing and the yellow wire) this is normal.  If this reads as an open circuit (infinite resistance) the wire may be broken internally or the soldering either to the stator or to the lucar terminal may not be making a connection.

2.1  Check you have power coming out of the regulator.  Plug the yellow wire from step 1 back in to the regulator (silver/ grey box with cooling fins and three wires connected to it).  Take the loom wire out of the regulator (usually brown) now using your test bulb check for a feed out of the regulator by touching your test wire on to the terminal on the regulator from which you unplugged the brown loom wire.

(Working) If the bulb lights up with the bike ticking over the electronic kit is doing its job perfectly, you can now move to check 3.
(Not Working) If the bulb does not light up, you can be confident the problem is with your regulator.  This typically means that the earth on the regulator is not working; check this and the frame to engine earth.  Also check the soldering and terminals on the connections to the regulator make sure they are making good connections.  Finally try a new regulator, making sure you use an AC lambretta regulator.

2.2 If you do not have a junction box move to step 3.  If you are running AC electrics with a junction box, With the bike ticking over check for a feed from the brown wire coming from your regulator in to the junction box.  Then keeping all the wires plugged in check for a feed from each of the wires other than the two greens.

(Working) If the bulb lights up with the bike ticking over you have a feed in to the loom, you can now move to check 3.
(Not Working) If the bulb does not light up, you can be confident the problem is with your junction box or the connections to it.  Check you have the correct junction box.  You should be able to see a half moon metal plate joining all the connectors on one side of the junction box but leaving the two greens separate.  (This plate is in the back of the junction box but is visible through the holes or if you pull the black circle off the back of the junction box.  If you have no metal plate you have the wrong junction box.  Check the soldering and fitment of each connection.

3 Check you have a feed coming from the loom in to the headset.  Remove the headset top so you have access to the headlamp-wiring block.  With the bike ticking over use your bulb tester to check for a feed from the terminals with the brown wires plugged in.

(Working) If the bulb lights up with the bike ticking over you have a feed from the loom up to the headset, and to the ignition switch and horn.  Move to check 5
(Not Working) If the bulb does not light up, you either have a break in the loom or in the connections of the head set block or the terminals crimped on to those wires.  Check each of these and either run a feed directly from the regulator up to the headset or replace the loom.

4 Check you have a feed coming out of the ignition switch.  The orange wire provides the feed out of the ignition switch to the light switch for main and dip beam.  With the bike ticking over and the ignition switch in its third position (main lights on position) use your bulb tester to check for a feed on the orange wires connections.

(Working) If the bulb lights up with the bike ticking over you have a feed from the ignition switch in to the light switch. You can now go to step 5
(Not Working) If the bulb does not light up, you either have a break in one of the orange connections of the bulb holder or the terminals on the wire or a faulty ignition switch.

5 Check you have a feed out of the light switch.  With the bike ticking over and the ignition switch in its third position (main lights on position) use your bulb tester to check for a feed from either the red or the blue wire.  Then flip the dipswitch and check for a feed out of the red or blue wire that did not have a feed in the other position.

(Working) If the bulb lights up for both red and blue for they’re respective dipswitch position with the bike ticking over you have a feed from the light switch. To the head light bulb. Go to Step 6
(Not Working) If the bulb does not light up for one or both of those wires then you may have a damaged connection or solder point from the switch or its wires or a faulty switch

6 Check the earth wire for the headlights and festoon.  Usually a white wire coming from the side of the opposite side of the festoon bulb to its yellow feed.  Make sure this wire is making a good earth and that it has good connections.

(Working) if your lights now work you’re finished.
(Not Working) if your lights are still not working give us a call to trouble shoot and book some workshop time.